aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-04-15 15:09:59 +0200
committerRoel Janssen <roel@gnu.org>2021-04-16 11:20:21 +0200
commit44f9432705d04c069a8acf9e37e3ad856ac0bf82 (patch)
treee25faf388de7bed47ca3f2caa8f5a20735b4204d
parent6c7251f26ef225ffe2fcd24e374aff128d0615e4 (diff)
downloadguix-44f9432705d04c069a8acf9e37e3ad856ac0bf82.tar
guix-44f9432705d04c069a8acf9e37e3ad856ac0bf82.tar.gz
gnu: Add python-mappy.
* gnu/packages/python-xyz.scm (python-mappy): New variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d115790e1..5a4220541e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
-;;; Copyright © 2017, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
@@ -2020,6 +2020,28 @@ information created by most SVG editors. Optimization options are typically
lossless but can be tweaked for more aggressive cleaning.")
(license license:asl2.0)))
+(define-public python-mappy
+ (package
+ (name "python-mappy")
+ (version "2.18")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mappy" version))
+ (sha256
+ (base32
+ "1a05p7rkmxa6qhm108na8flzj2v45jab06drk59kzk1ip2sgvzqq"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/lh3/minimap2")
+ (synopsis "Python binding for minimap2")
+ (description "This package provides a convenient interface to minimap2,
+a fast and accurate C program to align genomic and transcribe nucleotide
+sequences.")
+ (license license:expat)))
+
(define-public python-mechanize
(package
(name "python-mechanize")