aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2020-11-30 14:24:05 -0600
committerChristopher Baines <mail@cbaines.net>2020-12-08 08:37:49 +0000
commit4368b9b2d7903430494b20db913c228c135a8668 (patch)
tree8124dc522866f47f6b67f7588e1008d062b831d6
parentd2a42cee0bfacc8afe752830f18c8356c396ed2d (diff)
downloadguix-4368b9b2d7903430494b20db913c228c135a8668.tar
guix-4368b9b2d7903430494b20db913c228c135a8668.tar.gz
gnu: Add go-github-com-gorilla-securecookie.
* gnu/packages/golang.scm (go-github-com-gorilla-securecookie): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1e372f6b3b..c3f5ee5d3b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1357,6 +1357,31 @@ incoming requests with their respective handler.")
and web applications.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-securecookie
+ (package
+ (name "go-github-com-gorilla-securecookie")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/securecookie")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16bqimpxs9vj5n59vm04y04v665l7jh0sddxn787pfafyxcmh410"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/securecookie"))
+ (home-page "https://github.com/gorilla/securecookie")
+ (synopsis "Encodes and decodes authenticated and optionally encrypted
+cookie values")
+ (description
+ "Gorilla/securecookie encodes and decodes authenticated and optionally
+encrypted cookie values for Go web applications.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jonboulle-clockwork
(let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))