aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWinterHound <winterhound@yandex.com>2021-04-18 15:55:23 +0530
committerLeo Famulari <leo@famulari.name>2021-04-18 14:43:01 -0400
commit3ddece896fddc38a29ab7e69f7c74f35e5a381fb (patch)
tree2880c79d37c0858dd4702f5b5dac506dd6e3d1cf
parente1bb900307dd84645a9f1d6ed88bc1c2a247fd8f (diff)
downloadguix-3ddece896fddc38a29ab7e69f7c74f35e5a381fb.tar
guix-3ddece896fddc38a29ab7e69f7c74f35e5a381fb.tar.gz
gnu: Add kirc.
* gnu/packages/irc.scm (kirc): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/irc.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 3953c55a20..36c4fac3c1 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2021 WinterHound <winterhound@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
@@ -376,6 +378,36 @@ for the IRCv3 protocol.")
"sic is a simple IRC client, even more minimalistic than ii.")
(license license:expat)))
+(define-public kirc
+ (package
+ (name "kirc")
+ (version "0.2.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mcpcpc/kirc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11pwbil44q7sm3mp1khgw8wmwln2n03f1qawlgmg168jzyxqrs16"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; No ./configure script
+ (synopsis "IRC client written in POSIX C99")
+ (description "Kirc is an Internet Relay Chat (IRC) client. It includes
+support for Simple Authentication and Security Layer (SASL), the
+client-to-client (CTCP) protocol, simple chat history logging, synchronous
+message handling, multi-channel joining at server connection, full support for
+all RFC 2812 commands, and customized color scheme definitions.")
+ (home-page "http://kirc.io/index.html")
+ (license license:expat)))
+
(define-public limnoria
(package
(name "limnoria")