aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2021-04-19 13:21:04 +0200
committerAndreas Enge <andreas@enge.fr>2021-04-19 13:21:44 +0200
commit0dda79405ef9e85c8180269d954a024fd152e9ef (patch)
tree332499798e6b710de77220167c20742520c3dba4
parentfe5c36728f9e1287f621070383c54387f487a4a1 (diff)
downloadguix-0dda79405ef9e85c8180269d954a024fd152e9ef.tar
guix-0dda79405ef9e85c8180269d954a024fd152e9ef.tar.gz
gnu: Add perl-digest-sha.
* gnu/packages/perl.scm (perl-digest-sha): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ba1af873c1..378a0dd20c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2019, 2020 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2019, 2020, 2021 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2019, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -3830,6 +3830,30 @@ input a message of arbitrary length and produces as output a
128-bit \"fingerprint\" or \"message digest\" of the input.")
(license (package-license perl))))
+(define-public perl-digest-sha
+ (package
+ (name "perl-digest-sha")
+ (version "6.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSHELOR/Digest-SHA-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "01lv0dc3mgnl3ap8npdnqiwmdqz2yc5bziss648c5jgalfzacric"))))
+ (build-system perl-build-system)
+ (home-page
+ "https://metacpan.org/release/Digest-SHA")
+ (synopsis
+ "Perl extension for SHA-1/224/256/384/512")
+ (description
+ "The @code{Digest::SHA} Perl module implements the hash functions
+of the SHA family. It also provides the @code{shasum} binary.")
+ (license (package-license perl))))
+
(define-public perl-digest-sha1
(package
(name "perl-digest-sha1")