aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-04-11 19:27:29 -0500
committerEric Bavier <bavier@member.fsf.org>2019-04-11 19:34:00 -0500
commitfb038f32ae7860936b0fa85035a1d020597919d2 (patch)
treed45fcfed4a07d4bfc717b71b43e22c408e9aaaed
parenta4df9ba4ec4def25232265d72722dcc348b9beb0 (diff)
downloadguix-fb038f32ae7860936b0fa85035a1d020597919d2.tar
guix-fb038f32ae7860936b0fa85035a1d020597919d2.tar.gz
gnu: Add ghc-libffi.
* gnu/packages/haskell.scm (ghc-libffi): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a23dfe9ae6..3d269cea83 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
-;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -833,6 +833,28 @@ code pages on Windows. On all other operating systems, the library does
nothing.")
(license license:bsd-3)))
+(define-public ghc-libffi
+ (package
+ (name "ghc-libffi")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "libffi/libffi-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g7jnhng3j7z5517aaqga0144aamibsbpgm3yynwyfzkq1kp0f28"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("libffi" ,libffi)))
+ (home-page "http://hackage.haskell.org/package/libffi")
+ (synopsis "Haskell binding to libffi")
+ (description
+ "A binding to libffi, allowing C functions of types only known at runtime
+to be called from Haskell.")
+ (license license:bsd-3)))
+
(define-public ghc-newtype-generics
(package
(name "ghc-newtype-generics")