aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:21:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:41 +0200
commitf86b4b56b1746ad5a75004e10b8f688f336b6145 (patch)
treec88c6f47ee3eaad2e9ce68387519a650ebf60219
parent0471c00109a97010232edbcc353b36da1327a8f1 (diff)
downloadguix-f86b4b56b1746ad5a75004e10b8f688f336b6145.tar
guix-f86b4b56b1746ad5a75004e10b8f688f336b6145.tar.gz
gnu: sbcl-trivial-garbage: Don't use unstable tarball.
* gnu/packages/lisp.scm (sbcl-trivial-garbage)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4e47c33b1b..5549f7ddc8 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3243,13 +3243,13 @@ precisely control behavior of the parser via Common Lisp restarts.")
(version "0.21")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/trivial-garbage/trivial-garbage/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trivial-garbage/trivial-garbage.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "trivial-garbage" version))
(sha256
- (base32 "0b244nlszkrqawsnp568clnx32xmvjmbbagbz7625w9n0yq7396y"))
- (file-name (string-append "trivial-garbage-" version ".tar.gz"))))
+ (base32 "0122jicfg7pca1wxw8zak1n92h5friqy60988ns0ysksj3fphw9n"))))
(build-system asdf-build-system/sbcl)
(native-inputs
`(("rt" ,sbcl-rt)))