aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-04 06:15:33 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-11 13:46:39 +0200
commitf74a90bf6cf7c7ee3b8c3997ab08c015339b92bb (patch)
tree91dff30be68bbae7491585e445a1bc7e1a65af8a
parenteccf816b64f2f07fda8cbfa8b013f9b3c9c6125a (diff)
downloadguix-f74a90bf6cf7c7ee3b8c3997ab08c015339b92bb.tar
guix-f74a90bf6cf7c7ee3b8c3997ab08c015339b92bb.tar.gz
gnu: Add emacs-evil-replace-with-register.
* gnu/packages/emacs-xyz.scm (emacs-evil-replace-with-register): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 205d01fca3..302288e08a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5655,6 +5655,32 @@ end of a line and increment or decrement it.")
for exchanging text.")
(license license:gpl3+))))
+(define-public emacs-evil-replace-with-register
+ (let ((commit "91cc7bf21a94703c441cc9212214075b226b7f67")
+ (version "0.1")
+ (revision "1"))
+ (package
+ (name "emacs-evil-replace-with-register")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dewdrops/evil-ReplaceWithRegister")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14rpn76qrf287s3y2agmddcxi27r226i53ixjvd694ss039g0r11"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)))
+ (home-page "https://github.com/Dewdrops/evil-ReplaceWithRegister")
+ (synopsis "Quickly replace text with the contents of a register")
+ (description
+ "This package provides an Evil operator for replacing text with the
+contents of a register.")
+ (license license:gpl3+))))
+
(define-public emacs-monroe
(package
(name "emacs-monroe")