aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:19:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commiteabcf02efdbbc0b427c0ceae402a3335d48aed12 (patch)
tree15dda3d1065abf3a1cd5e9e161c95883a4888860
parent574edcc006322f0ecc084820cb93234fa66e802a (diff)
downloadguix-eabcf02efdbbc0b427c0ceae402a3335d48aed12.tar
guix-eabcf02efdbbc0b427c0ceae402a3335d48aed12.tar.gz
gnu: sbcl-cl-ppcre: Don't use unstable tarball.
* gnu/packages/lisp.scm (sbcl-cl-ppcre)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 824027c5c5..38836dd291 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -855,13 +855,13 @@ streams which are similar to string streams.")
(version "2.0.11")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/edicl/cl-ppcre/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edicl/cl-ppcre.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-ppcre" version))
(sha256
- (base32 "1i7daxf0wnydb0pgwiym7qh2wy70n14lxd6dyv28sy0naa8p31gd"))
- (file-name (string-append "cl-ppcre-" version ".tar.gz"))))
+ (base32 "0q3iany07vgqm144lw6pj0af2d3vsikpbkwcxr30fci3kzsq4f49"))))
(build-system asdf-build-system/sbcl)
(native-inputs `(("flexi-streams" ,sbcl-flexi-streams)))
(synopsis "Portable regular expression library for Common Lisp")