aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-04-11 19:28:45 -0500
committerEric Bavier <bavier@member.fsf.org>2019-04-11 19:34:01 -0500
commite16bc71015a2cc59f49e27720c0a93bc4188ed81 (patch)
tree8175a8ae8e152d938b2d986a2290a54b914739b4
parentfb038f32ae7860936b0fa85035a1d020597919d2 (diff)
downloadguix-e16bc71015a2cc59f49e27720c0a93bc4188ed81.tar
guix-e16bc71015a2cc59f49e27720c0a93bc4188ed81.tar.gz
gnu: idris: Enable FFI and GMP support.
* gnu/packages/idris.scm (idris)[inputs]: Add ghc-libffi. [arguments]: Add "-fFFI" and "-fGMP" to #:configure-flags.
-rw-r--r--gnu/packages/idris.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 45e7a76de9..0f653d8dab 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -23,6 +23,7 @@
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-web)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (guix build-system gnu)
@@ -61,6 +62,7 @@
("ghc-fingertree" ,ghc-fingertree)
("ghc-fsnotify" ,ghc-fsnotify)
("ghc-ieee754" ,ghc-ieee754)
+ ("ghc-libffi" ,ghc-libffi)
("ghc-megaparsec" ,ghc-megaparsec)
("ghc-network" ,ghc-network)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
@@ -79,7 +81,8 @@
`(#:tests? #f ; FIXME: Test suite doesn't run in a sandbox.
#:configure-flags
(list (string-append "--datasubdir="
- (assoc-ref %outputs "out") "/lib/idris"))
+ (assoc-ref %outputs "out") "/lib/idris")
+ "-fFFI" "-fGMP")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'set-cc-command