aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:09 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:04 +0100
commitc093d8fbdd573c2dfbe5c7af69ec2bd7c7d6932e (patch)
tree034f6ca24416b7fb727ab4c86b16ee64f7ba6596
parent8e5d991e901fcc030179f363096154a6076efa92 (diff)
downloadguix-c093d8fbdd573c2dfbe5c7af69ec2bd7c7d6932e.tar
guix-c093d8fbdd573c2dfbe5c7af69ec2bd7c7d6932e.tar.gz
gnu: Add perl-uri-db.
* gnu/packages/perl-web.scm (perl-uri-db): New variable.
-rw-r--r--gnu/packages/perl-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 70294f9acb..77a66f71d0 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -50,6 +50,33 @@ used are outdated now, the idea behind it is not. Mojolicious is a new
endeavor to implement this idea using modern technologies.")
(license license:artistic2.0)))
+(define-public perl-uri-db
+ (package
+ (name "perl-uri-db")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/URI-db-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0n56xxlw7c39pfar0dxckr9mbmp6yrzk53ic0cb24raiykm9v6f4"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-uri" ,perl-uri)
+ ("perl-uri-nested" ,perl-uri-nested)))
+ (home-page "https://metacpan.org/release/URI-db")
+ (synopsis "Handle database URIs")
+ (description
+ "This module defines a format for database URIs, and provides a @{URI}
+class to handle these.")
+ (license license:perl-license)))
+
(define-public perl-uri-escape
(package
(name "perl-uri-escape")