aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:09:47 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:04 +0100
commitad54fd261c560529d036f6b87f9f51eff549e75d (patch)
tree68ad8ec33fb5c115c28965bcd7bf62fd3d0a7312
parentb13c2ba61e357a85267dee79f4cdde20cdfe29ed (diff)
downloadguix-ad54fd261c560529d036f6b87f9f51eff549e75d.tar
guix-ad54fd261c560529d036f6b87f9f51eff549e75d.tar.gz
gnu: Add perl-template-tiny.
* gnu/packages/perl.scm (perl-template-tiny): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f1131a0713..38cc5e77b0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8149,6 +8149,32 @@ documents: HTML, XML, POD, PostScript, LaTeX, and so on.")
processing in Perl code.")
(license (list gpl3 artistic2.0))))
+(define-public perl-template-tiny
+ (package
+ (name "perl-template-tiny")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AD/ADAMK/Template-Tiny-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0jhadxbc8rzbk2v8qvjrbhnvfp0m56iqar6d4nvxyl8bccn0cgh7"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Template-Tiny")
+ (synopsis "Template Toolkit reimplemented in as little code as possible")
+ (description
+ "@code{Template::Tiny} is a reimplementation of a subset of the
+functionality from Template Toolkit in as few lines of code as possible.
+
+It is intended for use in light-usage, low-memory, or low-cpu templating
+situations, where you may need to upgrade to the full feature set in the
+future, or if you want the retain the familiarity of TT-style templates.")
+ (license perl-license)))
+
(define-public perl-term-encoding
(package
(name "perl-term-encoding")