aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:13 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:04 +0100
commit8e5d991e901fcc030179f363096154a6076efa92 (patch)
tree59cab5190e2d32175968109a6508dc238ea5ae4e
parentad54fd261c560529d036f6b87f9f51eff549e75d (diff)
downloadguix-8e5d991e901fcc030179f363096154a6076efa92.tar
guix-8e5d991e901fcc030179f363096154a6076efa92.tar.gz
gnu: Add perl-uri-nested.
* gnu/packages/perl-web.scm (perl-uri-nested): New variable.
-rw-r--r--gnu/packages/perl-web.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 6ced2d160e..70294f9acb 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -21,9 +21,11 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (guix download)
- #:use-module (guix build-system perl))
+ #:use-module (guix build-system perl)
+ #:use-module (gnu packages web))
(define-public perl-mojolicious
(package
@@ -70,3 +72,29 @@ percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
informally called URI escaping. This is the terminology used by this module,
which predates the formalization of the terms by the RFC by several years.")
(license license:perl-license)))
+
+(define-public perl-uri-nested
+ (package
+ (name "perl-uri-nested")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/URI-Nested-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bzg6f11m8wfnmycflvp858rs99xknsx8hkip0xcdfjzlqwi75z1"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-uri" ,perl-uri)))
+ (home-page "https://metacpan.org/release/URI-Nested")
+ (synopsis "Nested URIs")
+ (description
+ "@code{URI::Nested} provides support for nested URIs, where the scheme is
+a prefix, and the remainder of the URI is another URI.")
+ (license license:perl-license)))