aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:09:43 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:05 +0100
commit7d5614b5099fa1a52803f93db5bdc538b90e75a4 (patch)
tree23c294efe79cf4a290cfb90c5ae0e5d126fb2ee8
parent2eccb92fe340547a2dd074f1af5c0f89565d9559 (diff)
downloadguix-7d5614b5099fa1a52803f93db5bdc538b90e75a4.tar
guix-7d5614b5099fa1a52803f93db5bdc538b90e75a4.tar.gz
gnu: Add perl-string-shellquote.
* gnu/packages/perl.scm (perl-string-shellquote): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 38cc5e77b0..86d07c3ccc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7716,6 +7716,28 @@ fixed string interpolation, and simple width-matching.")
known prefixes.")
(license (package-license perl))))
+(define-public perl-string-shellquote
+ (package
+ (name "perl-string-shellquote")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROSCH/String-ShellQuote-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dfxhr6hxc2majkkrm0qbx3qcbykzpphbj2ms93dc86f7183c1p6"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/String-ShellQuote")
+ (synopsis "Quote strings for passing through a shell")
+ (description
+ "@code{shell-quote} lets you pass arbitrary strings through the shell so
+that they won't be changed.")
+ (license (package-license perl))))
+
(define-public perl-string-print
(package
(name "perl-string-print")