aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:09:51 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:03 +0100
commit6d08b0e298ec4aeafce53f773f2ed0ff4b049001 (patch)
tree9c6958baf9dd13c79e83cc5bb9d7ae00cbd78fdb
parentb6eacbe794e46800107ab3454c85a6eac87f2bb8 (diff)
downloadguix-6d08b0e298ec4aeafce53f773f2ed0ff4b049001.tar
guix-6d08b0e298ec4aeafce53f773f2ed0ff4b049001.tar.gz
gnu: Add perl-tie-handle-offset.
* gnu/packages/perl.scm (perl-tie-handle-offset): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 195cf6592c..fd8a47825f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8654,6 +8654,28 @@ can also be set to any arbitrary supplied order. The familiar perl array
operations can also be performed on the IxHash.")
(license (package-license perl))))
+(define-public perl-tie-handle-offset
+ (package
+ (name "perl-tie-handle-offset")
+ (version "0.004")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/Tie-Handle-Offset-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "17m8s8314wi4g0wasdxk15rf12vzsgzmcbr598jam5f6bl2kk7zf"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Tie-Handle-Offset")
+ (synopsis "Special file handle that hides the beginning of a file")
+ (description
+ "This modules provides a file handle that hides the beginning of a file,
+by modifying the @code{seek()} and @code{tell()} calls.")
+ (license asl2.0)))
+
(define-public perl-tie-toobject
(package
(name "perl-tie-toobject")