aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-04-11 17:52:24 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-04-11 17:52:52 +0200
commit6a8c4b9e11996bad04ce7685664895b0064d9a8b (patch)
tree6dffc65721a04b5cb72f087617200d2dbcf3829b
parentce6312999f20bb8d7e73c29b315747b1f4d184aa (diff)
downloadguix-6a8c4b9e11996bad04ce7685664895b0064d9a8b.tar
guix-6a8c4b9e11996bad04ce7685664895b0064d9a8b.tar.gz
gnu: Add vhba-module.
* gnu/packages/linux.scm (vhba-module): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 710fd2d299..dfd6bed76b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -118,6 +118,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system linux-module)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -438,6 +439,28 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-5.0-patches
#:configuration-file kernel-config))
+(define-public vhba-module
+ (package
+ (name "vhba-module")
+ (version "20170610")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.sourceforge.net/cdemu/vhba-module-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1v6r0bgx0a65vlh36b1l2965xybngbpga6rp54k4z74xk0zwjw3r"))))
+ (build-system linux-module-build-system)
+ (arguments
+ ;; TODO: No tests?
+ `(#:tests? #f))
+ (home-page "https://cdemu.sourceforge.io/")
+ (synopsis "Kernel module that emulates SCSI devices")
+ (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+ (license license:gpl2+)))
+
(define %linux-libre-4.19-version "4.19.34")
(define %linux-libre-4.19-hash "0rmpyj2qb651p2k2srpjndjxry87hr5vq0jkk4rvxjhm5y3sb65l")