aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:20:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:41 +0200
commit4d2c51dec2aa90051a139579a664cb0842a088c9 (patch)
tree29d3277f4646ed843e7cbbd72c9ea60e946af9c1
parenteabcf02efdbbc0b427c0ceae402a3335d48aed12 (diff)
downloadguix-4d2c51dec2aa90051a139579a664cb0842a088c9.tar
guix-4d2c51dec2aa90051a139579a664cb0842a088c9.tar.gz
gnu: stumpwm: Don't use unstable tarball.
* gnu/packages/lisp.scm (stumpwm)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/lisp.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 38836dd291..91df75757f 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -980,18 +980,19 @@ from other CLXes around the net.")
(package
(name "stumpwm")
(version "18.11")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/stumpwm/stumpwm/archive/"
- version ".tar.gz"))
- (sha256
- (base32 "177gxfk4c127i9crghx6fmkipznhgylvzgnjb2pna38g21gg6s39"))
- (file-name (string-append "stumpwm-" version ".tar.gz"))
- (patches
- ;; This patch is included in the post-18.11 git master tree
- ;; and can be removed when we move to the next release.
- (search-patches "stumpwm-fix-broken-read-one-line.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stumpwm/stumpwm.git")
+ (commit version)))
+ (file-name (git-file-name "stumpwm" version))
+ (sha256
+ (base32 "003g1fmh7446ws49866kzny4lrk1wf034dq5fa4m9mq1nzc7cwv7"))
+ (patches
+ ;; This patch is included in the post-18.11 git master tree
+ ;; and can be removed when we move to the next release.
+ (search-patches "stumpwm-fix-broken-read-one-line.patch"))))
(build-system asdf-build-system/sbcl)
(native-inputs `(("fiasco" ,sbcl-fiasco)
("texinfo" ,texinfo)))