aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2019-03-01 09:07:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-04-13 11:12:15 +0200
commit296ea15cf39331f7ea3de49feb3fc680545d9034 (patch)
tree32dd166c965796c82d52744fe0d904721d6f54c6
parent472af999502edef5a8cc61b44a363bfa0397f8f1 (diff)
downloadguix-296ea15cf39331f7ea3de49feb3fc680545d9034.tar
guix-296ea15cf39331f7ea3de49feb3fc680545d9034.tar.gz
gnu: Add r-rex.
* gnu/packages/cran.scm (r-rex): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bf76e77b04..47cd1d7217 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13864,3 +13864,27 @@ making it possible to download files over HTTPS across platforms. The
@code{RCurl} package provides this functionality (and much more) but has
external dependencies. This package has is implemented purely in R.")
(license license:gpl2)))
+
+(define-public r-rex
+ (package
+ (name "r-rex")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rex" version))
+ (sha256
+ (base32
+ "0alsadgjgass3wr8y5d247j12qqzg454sc84vpskclrkmz778g5x"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lazyeval" ,r-lazyeval)
+ ("r-magrittr" ,r-magrittr)))
+ (home-page "https://github.com/kevinushey/rex")
+ (synopsis "Friendly regular expressions")
+ (description
+ "This package provides a friendly interface for the construction of
+regular expressions. Regular expressions are a very powerful feature, however
+they are often difficult to interpret. Rex allows you to build complex
+regular expressions from human readable expressions")
+ (license license:expat)))