aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:20 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:35:04 +0100
commit0caf693a2506db443d7b97638c38b4795fa28196 (patch)
tree6790e3f1206d7f597a42d303393a7818b72eb0a0
parentc093d8fbdd573c2dfbe5c7af69ec2bd7c7d6932e (diff)
downloadguix-0caf693a2506db443d7b97638c38b4795fa28196.tar
guix-0caf693a2506db443d7b97638c38b4795fa28196.tar.gz
gnu: Add perl-test-checkdeps.
* gnu/packages/perl-check.scm (perl-test-checkdeps): New variable.
-rw-r--r--gnu/packages/perl-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a25c43cc32..41724f54b1 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -142,6 +142,30 @@ framework base class. It concentrates on offering reusable data driven
patterns, so that you can write tests with a minimum of code.")
(license perl-license)))
+(define-public perl-test-checkdeps
+ (package
+ (name "perl-test-checkdeps")
+ (version "0.010")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LE/LEONT/Test-CheckDeps-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1vjinlixxdx6gfcw8y1dw2rla8bfhi8nmgcqr3nffc7kqskcrz36"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-cpan-meta-check" ,perl-cpan-meta-check)))
+ (home-page "https://metacpan.org/release/Test-CheckDeps")
+ (synopsis "Check for presence of dependencies")
+ (description
+ "This module provides a test that checks all dependencies have been
+installed properly.")
+ (license perl-license)))
+
(define-public perl-test-class
(package
(name "perl-test-class")