aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:20:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:41 +0200
commit0471c00109a97010232edbcc353b36da1327a8f1 (patch)
tree578da22092e353808c6f86136208329711a2c0f2
parent9769caa991cc5d76e6cb1c78bdfc21f55ba4c871 (diff)
downloadguix-0471c00109a97010232edbcc353b36da1327a8f1.tar
guix-0471c00109a97010232edbcc353b36da1327a8f1.tar.gz
gnu: sbcl-babel: Don't use unstable tarball.
* gnu/packages/lisp.scm (sbcl-babel)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 9d1b113530..4e47c33b1b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1699,13 +1699,13 @@ with a focus on interactive development.")
(version "0.5.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/cl-babel/babel/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cl-babel/babel.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "babel" version))
(sha256
- (base32 "189kgbmslh36xx0d2i1g6a7mcvjryvjzkdlnhilqy5xs7hkyqirq"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "139a8rn2gnhj082n8jg01gc8fyr63hkj57hgrnmb3d1r327yc77f"))))
(build-system asdf-build-system/sbcl)
(native-inputs
`(("tests:cl-hu.dwim.stefil" ,sbcl-hu.dwim.stefil)))