aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:18:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit02fbb5c3041b37b2a833ea632d4e76fdcb1900cc (patch)
tree6c292494c48bfbcf2c224d2e6c0f6ccd789a9d1d
parent8fa2bcc7935a27bba9aa03cbee5d1c3b4a014e9b (diff)
downloadguix-02fbb5c3041b37b2a833ea632d4e76fdcb1900cc.tar
guix-02fbb5c3041b37b2a833ea632d4e76fdcb1900cc.tar.gz
gnu: sbcl-fiveam: Don't use unstable tarball.
* gnu/packages/lisp.scm (sbcl-fiveam)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5a30e7c1dd..1cb62ae74b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -691,13 +691,13 @@ portable between implementations.")
(version "1.2")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/sionescu/fiveam/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sionescu/fiveam.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "fiveam" version))
(sha256
- (base32 "0f48pcbhqs3wwwzjl5nk57d4hcbib4l9xblxc66b8c2fhvhmhxnv"))
- (file-name (string-append "fiveam-" version ".tar.gz"))))
+ (base32 "1yx9716mk8pq9076q6cjx4c9lyax3amiccy37sh0913k2x8gsm4l"))))
(inputs `(("alexandria" ,sbcl-alexandria)))
(build-system asdf-build-system/sbcl)
(synopsis "Common Lisp testing framework")