aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-17 18:24:37 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-12-26 09:37:43 +0200
commit7e476ae819a156315e3fdf8f8118c287c1ed8aa4 (patch)
tree4561cecea0bf976ca8b84d54ea429c6c17a977ba
parentb9d8aa093587e5906bf23422a662addd21cfcb0b (diff)
downloadguix-7e476ae819a156315e3fdf8f8118c287c1ed8aa4.tar
guix-7e476ae819a156315e3fdf8f8118c287c1ed8aa4.tar.gz
gnu: Add python-pathos.
* gnu/packages/python-xyz.scm (python-pathos): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c06c2199de..0f9afe66be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16987,6 +16987,34 @@ discovery of what has been installed on an operating system, and where the
essential tools are located.")
(license license:bsd-3)))
+(define-public python-pathos
+ (package
+ (name "python-pathos")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathos" version))
+ (sha256
+ (base32
+ "0in8hxdz7k081ijn6q94gr39ycy7363sx4zysmbwyvd7snqjrbi1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dill" ,python-dill)
+ ("python-multiprocess" ,python-multiprocess)
+ ("python-pox" ,python-pox)
+ ("python-ppft" ,python-ppft)))
+ (home-page "https://pypi.org/project/pathos/")
+ (synopsis
+ "Parallel graph management and execution in heterogeneous computing")
+ (description
+ "Python-pathos is a framework for heterogenous computing. It provides a
+consistent high-level interface for configuring and launching parallel
+computations across heterogenous resources. Python-pathos provides configurable
+launchers for parallel and distributed computing, where each launcher contains
+the syntactic logic to configure and launch jobs in an execution environment.")
+ (license license:bsd-3)))
+
(define-public python-flit
(package
(name "python-flit")