aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-20 11:03:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-23 22:32:50 +0200
commit6ed192a2933f295ba195d4a27a885bd3264dde05 (patch)
tree36de4f2d1a10b2ff7ced39ff579750ed35e83626
parent62973d2550ee1b98bbadfb4c99231862399c57d7 (diff)
downloadguix-6ed192a2933f295ba195d4a27a885bd3264dde05.tar
guix-6ed192a2933f295ba195d4a27a885bd3264dde05.tar.gz
gnu: Add mpv-mpris.
* gnu/packages/video.scm (mpv-mpris): New variable.
-rw-r--r--gnu/packages/video.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ef60767236..1696560787 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1436,6 +1436,49 @@ projects while introducing many more.")
(define-public gnome-mpv
(deprecated-package "gnome-mpv" celluloid))
+(define-public mpv-mpris
+ (package
+ (name "mpv-mpris")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hoyon/mpv-mpris")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06hq3j1jjlaaz9ss5l7illxz8vm5bng86jl24kawglwkqayhdnjx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "mpris.so" (string-append out "/lib")))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("mpv" ,mpv)))
+ (home-page "https://github.com/hoyon/mpv-mpris")
+ (synopsis "MPRIS plugin for mpv")
+ (description "This package provides an @dfn{MPRIS} (Media Player Remote
+Interfacing Specification) plugin for the @code{mpv} media player. It implements
+@code{org.mpris.MediaPlayer2} and @code{org.mpris.MediaPlayer2.Player} D-Bus
+interfaces.
+
+To load this plugin, specify the following option when starting mpv:
+@code{--script $GUIX_PROFILE/lib/mpris.so} or link it into
+@file{$HOME/.config/mpv/scripts}.")
+ (license license:expat)))
+
(define-public libvpx
(package
(name "libvpx")