aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2019-12-25 01:22:00 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-25 01:22:00 -0600
commit6b520177734e1c144fd6394f801919d0b54fa23e (patch)
tree6a46215361b567d64b9ee21ba55c817296b72632
parent0cf6f606a83bab70cf68273e38025bc48e6897ce (diff)
downloadguix-6b520177734e1c144fd6394f801919d0b54fa23e.tar
guix-6b520177734e1c144fd6394f801919d0b54fa23e.tar.gz
gnu: Add python-fastentrypoints.
* gnu/packages/python-xyz.scm (python-fastentrypoints): New variable. Signed-off-by: Brett Gilio <brettg@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f90505c903..5433f4f1d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17025,3 +17025,25 @@ are included automatically.")
(description "Pattern matching and various utilities for file systems
paths.")
(license license:expat)))
+
+(define-public python-fastentrypoints
+ (package
+ (name "python-fastentrypoints")
+ (version "0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastentrypoints" version))
+ (sha256
+ (base32
+ "02s1j8i2dzbpbwgq2a3fiqwm3cnmhii2qzc0k42l0rdxd4a4ya7z"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/ninjaaron/fast-entry_points")
+ (synopsis
+ "Makes entry_points specified in setup.py load more quickly")
+ (description
+ "Using entry_points in your setup.py makes scripts that start really
+slowly because it imports pkg_resources. This package allows such setup
+scripts to load entry points more quickly.")
+ (license license:bsd-3)))