aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-23 17:29:51 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-23 17:30:25 -0600
commit65f84096366c810cca8246b9886e7aeddc3a8a30 (patch)
tree5119f62ad5bc6d21b49c81078eda70cf6f4c424d
parent6608727262f45d351c55cd1ae40414db7768a374 (diff)
downloadguix-65f84096366c810cca8246b9886e7aeddc3a8a30.tar
guix-65f84096366c810cca8246b9886e7aeddc3a8a30.tar.gz
gnu: python-numba: Update to 0.46.0.
* gnu/packages/python-xyz.scm (python-numba): Update to 0.46.0. [arguments]: Fix typos. [arguments]: Disable tests that can not detect Python front-end.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b01231c29..d5d958ca07 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15544,14 +15544,14 @@ validation testing and application logic.")
(define-public python-numba
(package
(name "python-numba")
- (version "0.42.0")
+ (version "0.46.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "numba" version))
(sha256
(base32
- "03rqdfx0512lcri2bcpngx5k3jwfbqnanqj3n19c7d6h6hqxvq9x"))))
+ "1vnfzcq6fcnkmdms6114d49awvvj5181fl7z1wlha27qc2paxjy2"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -15568,7 +15568,7 @@ validation testing and application logic.")
#t))
(add-after 'unpack 'remove-failing-tests
(lambda _
- ;; FIXME: these tests fail for unknown reasons:
+ ;; FIXME: These tests fail for unknown reasons:
;; test_non_writable_pycache, test_non_creatable_pycache, and
;; test_frozen (all in numba.tests.test_dispatcher.TestCache).
(substitute* "numba/tests/test_dispatcher.py"
@@ -15581,10 +15581,20 @@ validation testing and application logic.")
;; These tests fail because we don't run the tests from the build
;; directory: test_setup_py_distutils, test_setup_py_setuptools
- ;; They ar in numba.tests.test_pycc.TestDistutilsSupport.
+ ;; They are in numba.tests.test_pycc.TestDistutilsSupport.
(substitute* "numba/tests/test_pycc.py"
(("def test(_setup_py_distutils|_setup_py_setuptools)" _ m)
(string-append "def guix_skip" m)))
+
+ ;; These tests fail because our version of Python does not have
+ ;; a recognizable front-end for the Numba distribution to use
+ ;; to check against.
+ (substitute* "numba/tests/test_entrypoints.py"
+ (("def test(_init_entrypoint)" _ m)
+ (string-append "def guix_skip" m)))
+ (substitute* "numba/tests/test_jitclasses.py"
+ (("def test(_jitclass_longlabel_not_truncated)" _ m)
+ (string-append "def guix_skip" m)))
#t))
(replace 'check
(lambda _