aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-16 15:16:43 +0800
committerLudovic Courtès <ludo@gnu.org>2018-10-19 23:39:37 +0200
commitbc83b2e22f39c00ab3d0072c9c8f13285f7967d6 (patch)
tree008a6d39a2a8380119661f20e0cb0be5f9ef306b
parentcdb84eb0e6a2c0a885c742c01615c5c0e3c04124 (diff)
downloadguix-bc83b2e22f39c00ab3d0072c9c8f13285f7967d6.tar
guix-bc83b2e22f39c00ab3d0072c9c8f13285f7967d6.tar.gz
gnu: Add i3blocks.
* gnu/packages/wm.scm (i3blocks): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7c58770de7..68d497e955 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -233,6 +234,46 @@ from scratch. i3 is primarily targeted at advanced users and
developers.")
(license license:bsd-3)))
+(define-public i3blocks
+ (let ((commit "37f23805ff886639163fbef8aedba71c8071eff8")
+ (revision "1"))
+ (package
+ (name "i3blocks")
+ (version (string-append "1.4-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vivien/i3blocks.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "15rnrcajzyrmhlz1a21qqsjlj3dkib70806dlb386fliylc2kisb"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _ (invoke "sh" "autogen.sh")))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man1 (string-append out "/share/man/man1")))
+ (install-file "docs/i3blocks.1" man1)
+ #t))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/vivien/i3blocks")
+ (synopsis "Minimalist scheduler for status bar scripts")
+ (description "i3blocks executes your command lines and generates a
+status line from their output. The generated line is meant to be displayed by
+the i3 window manager through its i3bar component, as an alternative to
+i3status.")
+ (license license:gpl3+))))
+
(define-public perl-anyevent-i3
(package
(name "perl-anyevent-i3")