aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 15:08:45 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 15:08:45 +0200
commitb718793e2a3e09f458d93f1a000846308a7eb878 (patch)
treecb642b48ce1546f099917f8bf4db626d06f41965
parent0fd874ebd11324139ddf976a39d99e6bb6f6996f (diff)
downloadguix-b718793e2a3e09f458d93f1a000846308a7eb878.tar
guix-b718793e2a3e09f458d93f1a000846308a7eb878.tar.gz
gnu: Add texlive-latex-ms.
* gnu/packages/tex.scm (texlive-latex-ms): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be75bda7dd..9026c25596 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4492,3 +4492,33 @@ including:
It also ensures compatibility with the @code{media9} and @code{animate} packages.")
(license license:lppl)))
+
+(define-public texlive-latex-ms
+ (package
+ (name "texlive-latex-ms")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "ms"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0m4wx3yjb5al1qsv995z8fii8xxy96mcfihbnlx43lpgayiwz35s"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/ms"
+ #:tex-format "latex"))
+ (home-page "https://ctan.org/pkg/ms")
+ (synopsis "Various LATEX packages by Martin Schröder")
+ (description
+ "A bundle of LATEX packages by Martin Schröder; the collection comprises:
+
+@itemize
+@item @command{count1to}, make use of fixed TEX counters;
+@item @command{everysel}, set commands to execute every time a font is selected;
+@item @command{everyshi}, set commands to execute whenever a page is shipped out;
+@item @command{multitoc}, typeset the table of contents in multiple columns;
+@item @command{prelim2e}, mark typeset pages as preliminary; and
+@item @command{ragged2e}, typeset ragged text and allow hyphenation.
+@end itemize\n")
+ (license license:lppl1.3c+)))