aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 16:54:06 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:56:37 +0200
commita3bdddc359643a9a32e78e32b919390041818c49 (patch)
treec5b644dcdfb70ecfed59f25873729584ceb65964
parent9ecc457b52186fd96a63aeb1d8b9f2eda169f287 (diff)
downloadguix-a3bdddc359643a9a32e78e32b919390041818c49.tar
guix-a3bdddc359643a9a32e78e32b919390041818c49.tar.gz
gnu: Add sbcl-cl-cffi-gtk-gdk-pixbuf.
* gnu/packages/lisp.scm (sbcl-cl-cffi-gtk-gdk-pixbuf): New variable.
-rw-r--r--gnu/packages/lisp.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index dc0481dd95..b63a55f4ac 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3378,3 +3378,22 @@ is a library for creating graphical user interfaces.")
(("libpango" all)
(string-append
(assoc-ref inputs "pango") "/lib/" all))))))))))
+
+(define-public sbcl-cl-cffi-gtk-gdk-pixbuf
+ (package
+ (inherit sbcl-cl-cffi-gtk-boot0)
+ (name "sbcl-cl-cffi-gtk-gdk-pixbuf")
+ (inputs
+ `(("gdk-pixbuf" ,gdk-pixbuf)
+ ("cl-cffi-gtk-gobject" ,sbcl-cl-cffi-gtk-gobject)
+ ,@(package-inputs sbcl-cl-cffi-gtk-boot0)))
+ (arguments
+ `(#:asd-file "gdk-pixbuf/cl-cffi-gtk-gdk-pixbuf.asd"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "gdk-pixbuf/gdk-pixbuf.init.lisp"
+ (("libgdk_pixbuf" all)
+ (string-append
+ (assoc-ref inputs "gdk-pixbuf") "/lib/" all))))))))))