aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-01 15:28:56 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:54:12 +0200
commit9f3000cc11c0b0bb3c8da5dc5f4390243f1e0321 (patch)
treeff8e97dec9254bded8defcc82695dfda8f76c69d
parent19a1c3be9773a6c6accee9e4e1d7f6319c49dfed (diff)
downloadguix-9f3000cc11c0b0bb3c8da5dc5f4390243f1e0321.tar
guix-9f3000cc11c0b0bb3c8da5dc5f4390243f1e0321.tar.gz
gnu: Add anaphora.
* gnu/packages/lisp.scm (cl-anaphora, ecl-anaphora, sbcl-anaphora): New variables.
-rw-r--r--gnu/packages/lisp.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5c25daff52..967b648506 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2333,6 +2333,37 @@ testing. It is an extension of the library written by Chris Riesbeck.")
(define-public ecl-lisp-unit
(sbcl-package->ecl-package sbcl-lisp-unit))
+(define-public sbcl-anaphora
+ (package
+ (name "sbcl-anaphora")
+ (version "0.9.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tokenrove/anaphora")
+ (commit version)))
+ (sha256
+ (base32
+ "19wfrk3asimznkli0x2rfy637hwpdgqyvwj3vhq9x7vjvyf5vv6x"))
+ (file-name (git-file-name "anaphora" version))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("rt" ,sbcl-rt)))
+ (synopsis "The anaphoric macro collection from Hell")
+ (description
+ "Anaphora is the anaphoric macro collection from Hell: it includes many
+new fiends in addition to old friends like @command{aif} and
+@command{awhen}.")
+ (home-page "https://github.com/tokenrove/anaphora")
+ (license license:public-domain)))
+
+(define-public cl-anaphora
+ (sbcl-package->cl-source-package sbcl-anaphora))
+
+(define-public ecl-anaphora
+ (sbcl-package->ecl-package sbcl-anaphora))
+
(define-public sbcl-ascii-strings
(let ((revision "1")
(changeset "5048480a61243e6f1b02884012c8f25cdbee6d97"))