aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 16:53:51 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:56:37 +0200
commit9ecc457b52186fd96a63aeb1d8b9f2eda169f287 (patch)
tree760d7154aa4d798a58befa983b1c5987d34d1a82
parent7176fe7c328f0b4778b5f600c563c8073d16b135 (diff)
downloadguix-9ecc457b52186fd96a63aeb1d8b9f2eda169f287.tar
guix-9ecc457b52186fd96a63aeb1d8b9f2eda169f287.tar.gz
gnu: Add sbcl-cl-cffi-gtk-pango.
* gnu/packages/lisp.scm (sbcl-cl-cffi-gtk-pango): New variable.
-rw-r--r--gnu/packages/lisp.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ac694e3e7e..dc0481dd95 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3357,3 +3357,24 @@ is a library for creating graphical user interfaces.")
(("libcairo" all)
(string-append
(assoc-ref inputs "cairo") "/lib/" all))))))))))
+
+(define-public sbcl-cl-cffi-gtk-pango
+ (package
+ (inherit sbcl-cl-cffi-gtk-boot0)
+ (name "sbcl-cl-cffi-gtk-pango")
+ (inputs
+ `(("pango" ,pango)
+ ("cl-cffi-gtk-glib" ,sbcl-cl-cffi-gtk-glib)
+ ("cl-cffi-gtk-gobject" ,sbcl-cl-cffi-gtk-gobject)
+ ("cl-cffi-gtk-cairo" ,sbcl-cl-cffi-gtk-cairo)
+ ,@(package-inputs sbcl-cl-cffi-gtk-boot0)))
+ (arguments
+ `(#:asd-file "pango/cl-cffi-gtk-pango.asd"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "pango/pango.init.lisp"
+ (("libpango" all)
+ (string-append
+ (assoc-ref inputs "pango") "/lib/" all))))))))))