aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-01 15:30:21 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:54:12 +0200
commit8caa928dd44421322805d623fd47ecb8854345fa (patch)
treed48e9f759ce28435fdfb61b623b99425631f01c2
parentd414223205d2007e0c08420b34fee178cb04e77b (diff)
downloadguix-8caa928dd44421322805d623fd47ecb8854345fa.tar
guix-8caa928dd44421322805d623fd47ecb8854345fa.tar.gz
gnu: Add cl-colors.
* gnu/packages/lisp.scm (cl-colors, ecl-cl-colors, sbcl-cl-colors): New variables.
-rw-r--r--gnu/packages/lisp.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3e9180fc9a..689a617850 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2449,6 +2449,47 @@ not counting tests)
(define-public ecl-let-plus
(sbcl-package->ecl-package sbcl-let-plus))
+(define-public sbcl-cl-colors
+ (let ((commit "827410584553f5c717eec6182343b7605f707f75"))
+ (package
+ (name "sbcl-cl-colors")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpapp/cl-colors")
+ (commit commit)))
+ (sha256
+ (base32
+ "0l446lday4hybsm9bq3jli97fvv8jb1d33abg79vbylpwjmf3y9a"))
+ (file-name (git-file-name "cl-colors" version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("let-plus" ,sbcl-let-plus)))
+ (synopsis "Simple color library for Common Lisp")
+ (description
+ "This is a very simple color library for Common Lisp, providing
+
+@itemize
+@item Types for representing colors in HSV and RGB spaces.
+@item Simple conversion functions between the above types (and also
+hexadecimal representation for RGB).
+@item Some predefined colors (currently X11 color names – of course the
+library does not depend on X11).Because color in your terminal is nice.
+@end itemize
+
+This library is no longer supported by its author.")
+ (home-page "https://github.com/tpapp/cl-colors")
+ (license license:boost1.0))))
+
+(define-public cl-colors
+ (sbcl-package->cl-source-package sbcl-cl-colors))
+
+(define-public ecl-cl-colors
+ (sbcl-package->ecl-package sbcl-cl-colors))
+
(define-public sbcl-ascii-strings
(let ((revision "1")
(changeset "5048480a61243e6f1b02884012c8f25cdbee6d97"))