aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-08-24 11:12:36 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:54:09 +0200
commit8c661ff1ef48839de868d204487dd69eda9f5ffa (patch)
tree77a4411f2ee45a6c6419ed6798686cfad3b95f11
parent99c61242292987e2eaae1ff32687ab019d225420 (diff)
downloadguix-8c661ff1ef48839de868d204487dd69eda9f5ffa.tar
guix-8c661ff1ef48839de868d204487dd69eda9f5ffa.tar.gz
gnu: Add trivial-features.
* gnu/packages/lisp.scm (cl-trivial-features, ecl-trivial-features, sbcl-trivial-features): New variables.
-rw-r--r--gnu/packages/lisp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ef745d0ed8..675c6dcaa4 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1557,3 +1557,30 @@ utilities that make it even easier to manipulate text in Common Lisp. It has
(define-public ecl-cl-strings
(sbcl-package->ecl-package sbcl-cl-strings))
+
+(define-public sbcl-trivial-features
+ (package
+ (name "sbcl-trivial-features")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/trivial-features/trivial-features/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0db1awn6jyhcfhyfvpjvfziprmq85cigf19mwbvaprhblydsag3c"))
+ (file-name (string-append "trivial-features-" version ".tar.gz"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments '(#:tests? #f))
+ (home-page "http://cliki.net/trivial-features")
+ (synopsis "Ensures consistency of @code{*FEATURES*} in Common Lisp")
+ (description "Trivial-features ensures that @code{*FEATURES*} is
+consistent across multiple Common Lisp implementations.")
+ (license license:expat)))
+
+(define-public cl-trivial-features
+ (sbcl-package->cl-source-package sbcl-trivial-features))
+
+(define-public ecl-trivial-features
+ (sbcl-package->ecl-package sbcl-trivial-features))