aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-09 12:05:23 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:56:37 +0200
commit2cc931db448430433b89326fce3a9815c63775df (patch)
tree06b359d29d808bf7449a5c02af6d18592052a42c
parentdedbf37e5d158bdc78d1fdff2c4c5151e6d32473 (diff)
downloadguix-2cc931db448430433b89326fce3a9815c63775df.tar
guix-2cc931db448430433b89326fce3a9815c63775df.tar.gz
gnu: Add cl-unix-opts.
* gnu/packages/lisp.scm (cl-unix-opts, ecl-unix-opts, sbcl-unix-opts): New variables.
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 959298f316..de50eb43de 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3162,3 +3162,36 @@ settings ensure a very simple mode of operation, similar to that provided by
(define-public ecl-cl-json
(sbcl-package->ecl-package sbcl-cl-json))
+
+(define-public sbcl-unix-opts
+ (package
+ (name "sbcl-unix-opts")
+ (version "0.1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libre-man/unix-opts")
+ (commit version)))
+ (file-name (git-file-name "unix-opts" version))
+ (sha256
+ (base32
+ "08djdi1ard09fijb7w9bdmhmwd98b1hzmcnjw9fqjiqa0g3b44rr"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/hankhero/cl-json")
+ (synopsis "Unix-style command line options parser")
+ (description
+ "This is a minimalistic parser of command line options. The main
+advantage of the library is the ability to concisely define command line
+options once and then use this definition for parsing and extraction of
+command line arguments, as well as printing description of command line
+options (you get --help for free). This way you don't need to repeat
+yourself. Also, @command{unix-opts} doesn't depend on anything and allows to
+precisely control behavior of the parser via Common Lisp restarts.")
+ (license license:expat)))
+
+(define-public cl-unix-opts
+ (sbcl-package->cl-source-package sbcl-unix-opts))
+
+(define-public ecl-unix-opts
+ (sbcl-package->ecl-package sbcl-unix-opts))