aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:39:37 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:28 -0600
commit0d3ec4951ee1d891f5853b4eadd95d3aa0c240e6 (patch)
treeaa0d878f08254cce14fdfc373de9aba0e0a5bf9b
parente8bba431a81872bb16a2497908477dbec1258224 (diff)
downloadguix-0d3ec4951ee1d891f5853b4eadd95d3aa0c240e6.tar
guix-0d3ec4951ee1d891f5853b4eadd95d3aa0c240e6.tar.gz
gnu: Add Algorithm-Diff.
* gnu/packages/perl.scm (perl-algorithm-diff): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fa25a8d36a..e4ede6a44b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -81,6 +81,28 @@
(home-page "http://www.perl.org/")
(license gpl1+))) ; or "Artistic"
+(define-public perl-algorithm-diff
+ (package
+ (name "perl-algorithm-diff")
+ (version "1.1903")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TY/TYEMQ/"
+ "Algorithm-Diff-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0l8pk7ziz72d022hsn4xldhhb9f5649j5cgpjdibch0xng24ms1h"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Algorithm-Diff")
+ (synopsis "Compute differences between two files or lists")
+ (description "This is a module for computing the difference between two
+files, two strings, or any other two lists of things. It uses an intelligent
+algorithm similar to (or identical to) the one used by the Unix \"diff\"
+program. It is guaranteed to find the *smallest possible* set of
+differences.")
+ (license (package-license perl))))
+
(define-public perl-archive-zip
(package
(name "perl-archive-zip")