aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-25 18:05:18 -0500
committerLeo Famulari <leo@famulari.name>2019-02-25 18:23:14 -0500
commitef5fa91ccc5d6ff7a5ce21df19541b57b98db4c7 (patch)
treee5f706c68019ccefcb659d256dda0fc9a7611b16
parent584dbd8568cca381682fb682b7daf7aa37bc7df8 (diff)
downloadguix-ef5fa91ccc5d6ff7a5ce21df19541b57b98db4c7.tar
guix-ef5fa91ccc5d6ff7a5ce21df19541b57b98db4c7.tar.gz
gnu: guile-emacs: Fetch source over HTTPS and be more idiomatic.
Fixes <https://bugs.gnu.org/27795>. * gnu/packages/emacs.scm (guile-emacs)[source]: Use HTTPS. Use git-version and git-file-name.
-rw-r--r--gnu/packages/emacs.scm68
1 files changed, 35 insertions, 33 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7e8dcadf96..821065c56f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -254,39 +254,41 @@ editor (without an X toolkit)" )
(package-arguments emacs)))))
(define-public guile-emacs
- (package (inherit emacs)
- (name "guile-emacs")
- (version "20150512.41120e0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.hcoop.net/git/bpt/emacs.git")
- (commit "41120e0f595b16387eebfbf731fff70481de1b4b")))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "guile-emacs-fix-configure.patch"))
- (sha256
- (base32
- "0lvcvsz0f4mawj04db35p1dvkffdqkz8pkhc0jzh9j9x2i63kcz6"))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("guile" ,guile-for-guile-emacs)
- ,@(package-native-inputs emacs)))
- (arguments
- (substitute-keyword-arguments `(;; Build fails if we allow parallel build.
- #:parallel-build? #f
- ;; Tests aren't passing for now.
- #:tests? #f
- ,@(package-arguments emacs))
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'autogen
- (lambda _
- (invoke "sh" "autogen.sh")))
- ;; Build sometimes fails: deps/dispnew.d: No such file or directory
- (add-before 'build 'make-deps-dir
- (lambda _
- (invoke "mkdir" "-p" "src/deps")))))))))
+ (let ((commit "41120e0f595b16387eebfbf731fff70481de1b4b")
+ (revision "0"))
+ (package (inherit emacs)
+ (name "guile-emacs")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.hcoop.net/git/bpt/emacs.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (patches (search-patches "guile-emacs-fix-configure.patch"))
+ (sha256
+ (base32
+ "0lvcvsz0f4mawj04db35p1dvkffdqkz8pkhc0jzh9j9x2i63kcz6"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("guile" ,guile-for-guile-emacs)
+ ,@(package-native-inputs emacs)))
+ (arguments
+ (substitute-keyword-arguments `(;; Build fails if we allow parallel build.
+ #:parallel-build? #f
+ ;; Tests aren't passing for now.
+ #:tests? #f
+ ,@(package-arguments emacs))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (invoke "sh" "autogen.sh")))
+ ;; Build sometimes fails: deps/dispnew.d: No such file or directory
+ (add-before 'build 'make-deps-dir
+ (lambda _
+ (invoke "mkdir" "-p" "src/deps"))))))))))
(define-public m17n-db
(package