aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-02-25 16:33:38 +0100
committerRutger Helling <rhelling@mykolab.com>2019-02-25 16:34:35 +0100
commite8ffa38289758e11412e83dad115a686965db78d (patch)
treeb5eb0be9b4d0e226f15b359402b4b467d8720f8b
parent589ce84d17efd712ea99fc5183e7526a8df70e87 (diff)
downloadguix-e8ffa38289758e11412e83dad115a686965db78d.tar
guix-e8ffa38289758e11412e83dad115a686965db78d.tar.gz
gnu: mgba: Update to 0.7.1.
* gnu/packages/emulators.scm (mgba): Update to 0.7.1. [inputs]: Add elfutils.
-rw-r--r--gnu/packages/emulators.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 184a3bc859..3a75e6a782 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages backup)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -406,7 +407,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(define-public mgba
(package
(name "mgba")
- (version "0.7.0")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -415,7 +416,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(file-name (git-file-name name version))
(sha256
(base32
- "0s4dl4pi8rxqahvzxnh37xdgsfax36cn5wlh1srdcmabwsrfpb3w"))
+ "0q0yg2zna7gjbvpaswyykbg3lr9k3c8l8fydqa407xrgq77lahq4"))
(modules '((guix build utils)))
(snippet
;; Make sure we don't use the bundled software.
@@ -433,7 +434,8 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(list "-DUSE_LZMA=OFF" ;do not use bundled LZMA
"-DUSE_LIBZIP=OFF"))) ;use "zlib" instead
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("ffmpeg" ,ffmpeg)
+ (inputs `(("elfutils" ,elfutils)
+ ("ffmpeg" ,ffmpeg)
("imagemagick" ,imagemagick)
("libedit" ,libedit)
("libepoxy" ,libepoxy)