aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-03-15 20:43:41 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-03-17 14:21:29 +0100
commitfef91c0cc8770c6c4fce08bd748e6f241a8cd682 (patch)
tree7d237085e5d3e7b829bddd47361647083518c477
parentbf6a1dbae1c08d6ee4ea1d169a1dd2f1ba7769ba (diff)
downloadguix-fef91c0cc8770c6c4fce08bd748e6f241a8cd682.tar
guix-fef91c0cc8770c6c4fce08bd748e6f241a8cd682.tar.gz
gnu: Move lolcode to esolangs.
* gnu/packages/lolcode.scm (lci): Move from here... * gnu/packages/esolangs.scm (lolcode-lci): ... to here. * gnu/packages/lolcode.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/esolangs.scm37
-rw-r--r--gnu/packages/lolcode.scm60
3 files changed, 37 insertions, 61 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index abb1e2140d..0422beac82 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -353,7 +353,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/logging.scm \
%D%/packages/logo.scm \
%D%/packages/loko.scm \
- %D%/packages/lolcode.scm \
%D%/packages/lsof.scm \
%D%/packages/lua.scm \
%D%/packages/lxde.scm \
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 676b355e65..45feedfa28 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Nikita <nikita@n0.is>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
@@ -22,6 +24,8 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -56,6 +60,39 @@ written in C. It supports several @dfn{fingerprints} (opt-in language extension
identified by unique ID codes).")
(license license:gpl3)))
+(define-public lolcode-lci
+ (package
+ (name "lolcode-lci")
+ (version "0.11.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/justinmeza/lci")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("python-2" ,python-2))) ; for the tests
+ (synopsis "LOLCODE interpreter written in C")
+ (description
+ "@code{lci} is a LOLCODE interpreter written in C and is designed to be
+correct, portable, fast, and precisely documented.
+@enumerate
+@item correct: Every effort has been made to test lci's conformance to the
+LOLCODE language specification. Unit tests come packaged with the lci source code.
+@item portable: lci follows the widely ported ANSI C specification allowing it
+to compile on a broad range of systems.
+@item fast: Much effort has gone into producing simple and efficient code
+whenever possible to the extent that the above points are not compromized.
+@end enumerate")
+ (home-page "http://lolcode.org/")
+ (license license:gpl3+)))
+
(define-public shakespeare-spl
(package
(name "shakespeare-spl")
diff --git a/gnu/packages/lolcode.scm b/gnu/packages/lolcode.scm
deleted file mode 100644
index cdbff1f4b6..0000000000
--- a/gnu/packages/lolcode.scm
+++ /dev/null
@@ -1,60 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Nikita <nikita@n0.is>
-;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lolcode)
- #:use-module (gnu packages)
- #:use-module (gnu packages python)
- #:use-module (gnu packages readline)
- #:use-module (guix build-system cmake)
- #:use-module (guix git-download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages))
-
-(define-public lci
- (package
- (name "lci")
- (version "0.11.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/justinmeza/lci")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
- (build-system cmake-build-system)
- (inputs
- `(("readline" ,readline)))
- (native-inputs
- `(("python-2" ,python-2))) ; for the tests
- (synopsis "LOLCODE interpreter written in C")
- (description
- "@code{lci} is a LOLCODE interpreter written in C and is designed to be
-correct, portable, fast, and precisely documented.
-@enumerate
-@item correct: Every effort has been made to test lci's conformance to the
-LOLCODE language specification. Unit tests come packaged with the lci source code.
-@item portable: lci follows the widely ported ANSI C specification allowing it
-to compile on a broad range of systems.
-@item fast: Much effort has gone into producing simple and efficient code
-whenever possible to the extent that the above points are not compromized.
-@end enumerate")
- (home-page "http://lolcode.org/")
- (license license:gpl3+)))