aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-16 14:16:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-16 14:17:47 +0100
commitfa0a18522d5c382f82a391e2eca3c1ca48b60834 (patch)
tree062e1d74ea9a486bb8e1c752e0d8b1ac00539d35
parentc9006a0ee107208c27769e4e4eb042ead0c2a62f (diff)
downloadguix-fa0a18522d5c382f82a391e2eca3c1ca48b60834.tar
guix-fa0a18522d5c382f82a391e2eca3c1ca48b60834.tar.gz
gnu: Add python-pulp.
* gnu/packages/python-xyz.scm (python-pulp): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e33debe10..ca00a8dc97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8007,6 +8007,28 @@ Python.")
structures.")
(license license:epl1.0)))
+(define-public python-pulp
+ (package
+ (name "python-pulp")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PuLP" version))
+ (sha256
+ (base32
+ "1dammrg0f1v0r028i3rpxbf2bsyxmjq0q6ihb4x2wsdki44z3bxj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-amply" ,python-amply)))
+ (home-page "https://github.com/coin-or/pulp")
+ (synopsis "Linear Programming modeler")
+ (description
+ "PuLP is a Linear Programming modeler written in Python. PuLP can
+generate MPS or LP files and call GLPK, COIN CLP/CBC, CPLEX, and GUROBI to
+solve linear problems.")
+ (license license:expat)))
+
(define-public snakemake
(package
(name "snakemake")