aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-03-15 23:02:20 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-03-16 09:37:16 +0200
commite5fcfb82e0eaf591fa6e8e390dbda842d239ef7c (patch)
treec59611b9ef38a00415181972d563c20d67aa4ec1
parent3679286bb4a69322048e1b8c17b161c4ad386769 (diff)
downloadguix-e5fcfb82e0eaf591fa6e8e390dbda842d239ef7c.tar
guix-e5fcfb82e0eaf591fa6e8e390dbda842d239ef7c.tar.gz
gnu: tmsu: Improve installation.
* gnu/packages/file-systems.scm (tmsu)[arguments]: Don't install go source files. Install binary as tmsu instead of TMSU. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e7d78e41fb..198653c639 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1174,7 +1175,16 @@ local file system using FUSE.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/oniony/TMSU"
- #:unpack-path ".."))
+ #:unpack-path ".."
+ #:install-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; The go build system produces /bin/TMSU -> install as /bin/tmsu
+ (rename-file (string-append out "/bin/TMSU")
+ (string-append out "/bin/tmsu"))))))))
(inputs
`(("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
("go-github-com-hanwen-fuse" ,go-github-com-hanwen-fuse)))