aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-26 12:49:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-26 13:59:39 +0100
commitf8a94609d3c068d9bbd01632652941fba0b3e937 (patch)
treecbedd2c1917793ebeaaf8ee86dd32742176c8a8e
parente272783bdb792bce28cd70f8b4c51d53658a0c7b (diff)
downloadguix-f8a94609d3c068d9bbd01632652941fba0b3e937.tar
guix-f8a94609d3c068d9bbd01632652941fba0b3e937.tar.gz
gnu: python-xmlschema: Update to 1.1.0.
* gnu/packages/xml.scm (python-xmlschema): Update to 1.1.0. [source]: Change to GIT-FETCH. [arguments]: Adjust test invokation.
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b931707acc..5e40ba1ec2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2108,13 +2108,17 @@ libxml2 and libxslt.")
(define-public python-xmlschema
(package
(name "python-xmlschema")
- (version "1.0.18")
+ (version "1.1.0")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "xmlschema" version))
+ ;; Unit tests are not distributed with the PyPI archive.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sissaschool/xmlschema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1inwqwr7d3qah9xf9rfzkpva433jpr4n7n43zybf2gdpz4q1g0ry"))))
+ "1h8321jb6q3dhlh3608y3f3sbbzfd3jg1psyirxkrm4w5xs3lbvy"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -2126,7 +2130,7 @@ libxml2 and libxslt.")
(setenv "PYTHONPATH"
(string-append "./build/lib:"
(getenv "PYTHONPATH")))
- (invoke "python" "xmlschema/tests/test_all.py"))
+ (invoke "python" "-m" "unittest" "-v"))
(format #t "test suite not run~%"))
#t)))))
(native-inputs