aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 20:41:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 20:41:58 +0100
commitf0731591a5f63917f757d7a9ebde081616a85b6a (patch)
tree36536eb3d8bb532500fdbe400022d25d3c8ed6bc
parentb8a6230df3fbbeeddb7a0e6976e0b8581bd0ab6e (diff)
downloadguix-f0731591a5f63917f757d7a9ebde081616a85b6a.tar
guix-f0731591a5f63917f757d7a9ebde081616a85b6a.tar.gz
gnu: idr: Fetch sources from git.
* gnu/packages/bioinformatics.scm (idr)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 28d66a1826..4d2b29c0ab 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3681,14 +3681,14 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
(name "idr")
(version "2.0.3")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/nboley/idr/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nboley/idr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1rjdly6daslw66r43g9md8znizlscn1sphycqyldzsidkc4vxqv3"))
+ "04j876h6z444v2q79drxx283d3k5snd72kj895wbalnl42206x9g"))
;; Delete generated C code.
(snippet
'(begin (delete-file "idr/inv_cdf.c") #t))))