aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 08:49:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:04:14 +0200
commitb7c591951468723f7a83d581f567136e497d081f (patch)
tree0591b77f77562eaabed773b41b7858008a736c69
parent9e1c358139d0029e8a0c6f4be9ce979976bfa07c (diff)
downloadguix-b7c591951468723f7a83d581f567136e497d081f.tar
guix-b7c591951468723f7a83d581f567136e497d081f.tar.gz
gnu: Add perl-xml-filter-buffertext.
* gnu/packages/xml.scm (perl-xml-filter-buffertext): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/xml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index f8aea6f90d..749ea81c58 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1313,3 +1313,27 @@ module/classes that implement trees. It is designed to be compatible with
@code{Class::XPath}, ie it passes its tests if you replace @code{Class::XPath}
by @code{Tree::XPathEngine}.")
(license license:perl-license)))
+
+(define-public perl-xml-filter-buffertext
+ (package
+ (name "perl-xml-filter-buffertext")
+ (version "1.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RB/RBERJON/"
+ "XML-Filter-BufferText-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0p5785c1dsk6kdp505vapb5h54k8krrz8699hpgm9igf7dni5llg"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-xml-sax-base" ,perl-xml-sax-base)))
+ (home-page "http://search.cpan.org/dist/XML-Filter-BufferText/")
+ (synopsis "Filter to put all characters() in one event")
+ (description "This is a very simple filter. One common cause of
+grief (and programmer error) is that XML parsers aren't required to provide
+character events in one chunk. They can, but are not forced to, and most
+don't. This filter does the trivial but oft-repeated task of putting all
+characters into a single event.")
+ (license license:perl-license)))