aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 16:43:17 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commitabf18075ca2669cdfa923a43f22f36a5bfc34a19 (patch)
tree463980985cf3b158347676fdb508250777d7306b
parent2dca669e45a233ec1391897b65faf51e347ace05 (diff)
downloadguix-abf18075ca2669cdfa923a43f22f36a5bfc34a19.tar
guix-abf18075ca2669cdfa923a43f22f36a5bfc34a19.tar.gz
gnu: Add perl-ipc-system-simple.
* gnu/packages/perl.scm (perl-ipc-system-simple): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ae6ad8f18e..74a47b4b4c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2792,6 +2792,30 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
allowing data to be efficiently communicated between processes.")
(license (package-license perl))))
+(define-public perl-ipc-system-simple
+ (package
+ (name "perl-ipc-system-simple")
+ (version "1.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PJ/PJF/IPC-System-Simple-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fsdb81shjj4hifyyzvj7vpkhq5jrfhlcpw2xbjfi1mqz8fsmdpi"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/IPC-System-Simple")
+ (synopsis "Run commands simply, with detailed diagnostics")
+ (description "Calling Perl's in-built @code{system} function is easy,
+determining if it was successful is hard. Let's face it, @code{$?} isn't the
+nicest variable in the world to play with, and even if you do check it,
+producing a well-formatted error string takes a lot of work.
+
+@code{IPC::System::Simple} takes the hard work out of calling external
+commands.")
+ (license (package-license perl))))
+
(define-public perl-json
(package
(name "perl-json")