aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-01-26 18:24:34 +0100
committerGuix Patches Tester <>2020-01-26 17:27:12 +0000
commita8f83e0df8c33bb4228d80264a499d401aa6e18b (patch)
treea369c0a7758b439fb13ef80591637cf8af93a258
parentddf8ff44276e10357cda7c891bc1306d4fad508a (diff)
downloadguix-a8f83e0df8c33bb4228d80264a499d401aa6e18b.tar
guix-a8f83e0df8c33bb4228d80264a499d401aa6e18b.tar.gz
gnu: Add python-pyprind
* gnu/packages/python-xyz.scm (python-pyprind): New variable.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a642662869..97122afe5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -169,6 +169,24 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-pyprind
+ (package
+ (name "python-pyprind")
+ (version "2.11.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPrind" version))
+ (sha256
+ (base32
+ "0xg6m5hr33h9bdlrr42kc58jm2m87a9zsagy7n2m4n407d2snv64"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-psutil" ,python-psutil)))
+ (home-page "https://github.com/rasbt/pyprind")
+ (synopsis "Python Progress Bar and Percent Indicator Utility")
+ (description "The PyPrind (Python Progress Indicator) module provides a progress bar and a percentage indicator object that let you track the progress of a loop structure or other iterative computation.")
+ (license license:bsd-3)))
+
(define-public python-gphoto2
(package
(name "python-gphoto2")