aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-07-02 14:28:35 -0400
committerLeo Famulari <leo@famulari.name>2016-07-03 16:52:19 -0400
commita2cb16b0c6bbb5558f6cce6a4c7c273126c9438f (patch)
tree05f20d780d46bbf46f47abae203a0372c3926d7e
parent47d0b29269576e763e1fa84d34aa3a7cff3e27b0 (diff)
downloadguix-a2cb16b0c6bbb5558f6cce6a4c7c273126c9438f.tar
guix-a2cb16b0c6bbb5558f6cce6a4c7c273126c9438f.tar.gz
gnu: Add alot.
* gnu/packages/mail.scm (alot): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/mail.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 58b46d8f67..24f8e3d02a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -397,6 +398,40 @@ messages you need; in addition, it allows you to view messages, extract
attachments, create new maildirs, and so on.")
(license gpl3+)))
+(define-public alot
+ (package
+ (name "alot")
+ (version "0.3.7")
+ (source (origin
+ (method url-fetch)
+ ; v0.3.7 not on PyPi yet, so use github instead
+ (uri (string-append "https://github.com/pazz/alot/archive/"
+ version ".tar.gz"))
+ (file-name (string-append "alot-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09md9llg38r6xby8l0y0zf8nhlh91cr4xs0r15b294hhp8hl2bgx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ ; python 3 is unsupported, more info:
+ ; https://github.com/pazz/alot/blob/0.3.7/docs/source/faq.rst
+ #:python ,python-2))
+ (inputs
+ `(("python2-magic" ,python2-magic)
+ ("python2-configobj" ,python2-configobj)
+ ("python2-twisted" ,python2-twisted)
+ ("python2-urwid" ,python2-urwid)
+ ("python2-urwidtrees" ,python2-urwidtrees)
+ ("python2-pygpgme" ,python2-pygpgme)
+ ("python2-notmuch" ,python2-notmuch)))
+ (home-page "https://github.com/pazz/alot")
+ (synopsis "Commandline MUA using notmuch")
+ (description
+ "Alot is an experimental terminal mail user agent (MUA) based on
+@code{notmuch} mail. It is written in Python using the @code{urwid} toolkit.")
+ (license gpl3+)))
+
(define-public notmuch
(package
(name "notmuch")