aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-01-26 18:24:32 +0100
committerGuix Patches Tester <>2020-01-26 17:27:10 +0000
commit9d413f8ea158d1e7ed5a4e32051f50ec0263d128 (patch)
tree71e609db586df7b055827bba078f638efcbae9c3
parent6cdb06c456d9bd98c2607812e3e9f3de2d07610e (diff)
downloadguix-9d413f8ea158d1e7ed5a4e32051f50ec0263d128.tar
guix-9d413f8ea158d1e7ed5a4e32051f50ec0263d128.tar.gz
gnu: Add python-colour
* gnu/packages/python-xyz.scm (python-colour): New variable.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 87f644c9ac..e59566c1d8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -169,6 +169,24 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-colour
+ (package
+ (name "python-colour")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "colour" version))
+ (sha256
+ (base32
+ "1visbisfini5j14bdzgs95yssw6sm4pfzyq1n3lfvbyjxw7i485g"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-d2to1" ,python-d2to1)))
+ (home-page "https://github.com/vaab/colour")
+ (synopsis "Convert and manipulate various color representations")
+ (description "Pythonic way to manipulate color representations (HSL, RVB, web, X11, ...).")
+ (license license:expat)))
+
(define-public python-d2to1
(package
(name "python-d2to1")