aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 15:51:23 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commit77ff12c98738aedcb7f54a8ba8bfd3ddacc0b83f (patch)
treef47f5874f8426db29611a802575b465b10dc31d4
parenta65d0fdb7cc8c517ea9ef70f83d7c89d3b60fb69 (diff)
downloadguix-77ff12c98738aedcb7f54a8ba8bfd3ddacc0b83f.tar
guix-77ff12c98738aedcb7f54a8ba8bfd3ddacc0b83f.tar.gz
gnu: Add perl-perlio-utf8-strict.
* gnu/packages/perl.scm (perl-perlio-utf8_strict): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 777fd37bdc..c62c79acaa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4136,6 +4136,29 @@ up inheritance from those modules at the same time.")
directory specifications in a cross-platform manner.")
(license (package-license perl))))
+(define-public perl-perlio-utf8_strict
+ (package
+ (name "perl-perlio-utf8-strict")
+ (version "0.006")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LE/LEONT/PerlIO-utf8_strict-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qnmiflirfq10jkmrxyy81ch6hzyndfzxqf8maif0fy44kk1004q"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (home-page
+ "http://search.cpan.org/dist/PerlIO-utf8_strict")
+ (synopsis "Fast and correct UTF-8 IO")
+ (description "@code{PerlIO::utf8_strict} provides a fast and correct UTF-8
+PerlIO layer. Unlike Perl's default @code{:utf8} layer it checks the input
+for correctness.")
+ (license (package-license perl))))
+
(define-public perl-pod-coverage
(package
(name "perl-pod-coverage")