aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-01-26 18:24:31 +0100
committerGuix Patches Tester <>2020-01-26 17:27:10 +0000
commit6cdb06c456d9bd98c2607812e3e9f3de2d07610e (patch)
tree621015f4e1acb9cb5aab755326bb76a1a69f6ed3
parent50178fe3fb8ede3a134fccaa48f1a490daf25b67 (diff)
downloadguix-6cdb06c456d9bd98c2607812e3e9f3de2d07610e.tar
guix-6cdb06c456d9bd98c2607812e3e9f3de2d07610e.tar.gz
gnu: Add python-d2to1
* gnu/packages/python-xyz.scm (python-d2to1): New variable.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f62996679d..87f644c9ac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -169,6 +169,24 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-d2to1
+ (package
+ (name "python-d2to1")
+ (version "0.2.12.post1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "d2to1" version))
+ (sha256
+ (base32
+ "09fq7pq1z8d006xh5z75rm2lk61v6yn2xhy53z4gsgibhqb2vvs9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/embray/d2to1")
+ (synopsis "Allows for distutils2-like setup.cfg files as package metadata in python")
+ (description "The python package d2to1 (the d is for distutils) allows using distutils2-like setup.cfg files for a package's metadata with a distribute/setuptools setup.py script.")
+ (license license:bsd-2)))
+
(define-public python-rawkit
(package
(name "python-rawkit")