aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-25 19:33:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-25 19:33:57 +0100
commit5b7fdc8289ce0adf85e881bc23d3537121b41193 (patch)
tree3acaaa26c12b1d0bd7168cf089cf385b2037f01c
parentdf6ce9fcb455ac59372f1025e450005ea3190614 (diff)
downloadguix-5b7fdc8289ce0adf85e881bc23d3537121b41193.tar
guix-5b7fdc8289ce0adf85e881bc23d3537121b41193.tar.gz
gnu: ode: Selectively disable tests.
* gnu/packages/game-development.scm (ode)[arguments]: Run tests only on x86_64.
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 72637a7929..13006f3509 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1998,7 +1998,10 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
#t))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;tests fail on all systems but x86_64
+ ;; Tests fail on all systems but x86_64.
+ `(#:tests? ,(string=? "x86_64-linux"
+ (or (%current-target-system)
+ (%current-system)))
#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
#:phases
(modify-phases %standard-phases