aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-07-02 14:27:41 -0400
committerLeo Famulari <leo@famulari.name>2016-07-03 16:52:19 -0400
commit47d0b29269576e763e1fa84d34aa3a7cff3e27b0 (patch)
treea2075864a89c21a3f3964c52307dd6921d4d4a11
parentb58c1b2d9b8f6d2aaee92a55804d7aa75f5f3499 (diff)
downloadguix-47d0b29269576e763e1fa84d34aa3a7cff3e27b0.tar
guix-47d0b29269576e763e1fa84d34aa3a7cff3e27b0.tar.gz
gnu: Add python-urwidtrees.
* gnu/packages/python.scm (python-urwidtrees, python2-urwidtrees): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 597ca6a033..8120012f77 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4488,6 +4489,30 @@ features useful for text console applications.")
(define-public python2-urwid
(package-with-python2 python-urwid))
+(define-public python-urwidtrees
+ (package
+ (name "python-urwidtrees")
+ (version "1.0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urwidtrees" version))
+ (sha256
+ (base32
+ "1zcvy12s7h3fazf33d6y7b4v19p8hg95xqwhqlmw6jz9fq76v9h8"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (inputs `(("python-urwid" ,python-urwid)))
+ (home-page "https://github.com/pazz/urwidtrees")
+ (synopsis "Tree widgets for urwid")
+ (description "Urwidtrees is a Widget Container API for the @code{urwid}
+toolkit. Use it to build trees of widgets.")
+ (license gpl3+)))
+
+(define-public python2-urwidtrees
+ (package-with-python2 python-urwidtrees))
+
(define-public python-dbus
(package
(name "python-dbus")