aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-01-26 18:24:36 +0100
committerGuix Patches Tester <>2020-01-26 17:27:13 +0000
commit312ed305ea5cc0ed007dcd15416f80d063d57877 (patch)
treebc70e7b0f5f7b3ad86c0702d2f9af2384cd7ff90
parent6ba76f2db8062fa7c7e8f0841e8772ca1b5bb5fa (diff)
downloadguix-312ed305ea5cc0ed007dcd15416f80d063d57877.tar
guix-312ed305ea5cc0ed007dcd15416f80d063d57877.tar.gz
gnu: Add python-tenacity
* gnu/packages/python-xyz.scm (python-tenacity): New variable.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dddcc89581..0a649793d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -169,6 +169,34 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-tenacity
+ (package
+ (name "python-tenacity")
+ (version "6.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "tenacity" version))
+ (sha256
+ (base32
+ "0w9miqmmi63yqp9lw7p6nf6gh5pa57vg60v6f94f11qqpg19gwvj"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-sphinx" ,python-sphinx)
+ ("python-tornado" ,python-tornado)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest"))))))
+ (home-page "https://github.com/jd/tenacity")
+ (synopsis "Retrying library for python")
+ (description "Tenacity is a general-purpose python library to simplify the task of adding retry behavior to just about anything.")
+ (license license:asl2.0)))
+
(define-public python-colorlog
(package
(name "python-colorlog")